Which mobile phones can be used to operate the BAGTAG?

Posted by Fernando Garcia on

Any mobile phone running Android 4.4 and higher or iPhones running iOS 8.4.1 or higher.

Older Post Newer Post

Notify me when my preferred airline works with BAGTAG

Let us know your questions and we will get back to you as soon as possible

Thanks!

My cart

Totaal
€79,95
CHECKOUT Continue shopping